Project

General

Profile

Bug #798

A crash occurs when clicking too often on the playback bar

Added by me 20 hours and 6 months ago. Updated 3 months ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Target version:
-
Start date:
June 23, 2018
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

If I click very often onto the playback bar to seek somewhere, audacious crashes with following message:

(audacious:3038): GLib-GIO-CRITICAL **: 19:26:32.083: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
audacious: ../../src/xcb_io.c:259: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
Abgebrochen

To be more precise, I used a key combination which executes a command to cause lots of clicks: xdotool click --repeat 300 --delay 10 1.

2018-08-08-122948_742x390_scrot.png (63.3 KB) 2018-08-08-122948_742x390_scrot.png I clicked where the arrow points to. me 20 hours and, August 08, 2018 10:32

History

#1 Updated by John Lindgren 6 months ago

I can't reproduce. What's the backtrace?

#2 Updated by me 20 hours and 6 months ago

Here's the gdb backtrace: https://pastebin.com/raw/vQrjKuj3

#3 Updated by John Lindgren 6 months ago

Try disabling all the plugins you can and see if the problem still occurs. I don't think anything in Audacious core does X11 stuff from a non-main thread, but maybe a plugin is misbehaving.

#4 Updated by me 20 hours and 5 months ago

I've tried it with default settings (by temporarily renaming ~/.config/audacious/) and it still happened.

#5 Updated by John Lindgren 5 months ago

Okay, now please try disabling all the plugins you can (even those enabled by default) and see if the problem still occurs.

#6 Updated by me 20 hours and 5 months ago

I've tried it on a mp3 file, the first time, playing stopped and I got this message:
ERROR ffaudio-core.cc:215 [log_result]: av_seek_frame failed: Vorgang nicht zulässig

I started playing and tried again, then it crashed:
WARNING ffaudio-core.cc:186 [mp3]: <0x7f1868095a80> Could not update timestamps for skipped samples.
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.

The crash also occurred with an ogg file.

#7 Updated by Thomas Lange 4 months ago

Could you make a screenshot of the area where you click? I cannot reproduce it as well.

#9 Updated by John Lindgren 4 months ago

Since others have not been able to reproduce this and it's a crash in a lower-level library that Audacious doesn't interact with directly, it seems to me that it might be a bug in a library that Audacious is using, such as GTK or one of its dependencies. There's probably not much anyone can do to debug it without physical access to the machine it's occurring on. I don't have any other suggestions, sorry.

#10 Updated by John Lindgren 3 months ago

  • Status changed from New to Rejected

Closing as not reproducible.

Also available in: Atom PDF