Project

General

Profile

Bug #86

Symbol collision: playlist_delete_selected

Added by Michael Schwendt over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Major
Assignee:
-
Category:
-
Target version:
Start date:
March 25, 2012
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

In the gtkui, pressing either the "Del" key or using the playlist context-menu "Cut" to delete/cut a track from the playlist fails since 3.2-beta1. Last version it worked in is 3.2-alpha1.

The Winamp gui is not affected.

History

#2 Updated by John Lindgren over 8 years ago

I am unable to reproduce. Also, will you explain the reasoning behind your patch?

#3 Updated by Michael Schwendt over 8 years ago

Without the renaming, I experience symbol collision between audacious-plugins /src/gtkui/ui_gtk.c and /src/audacious/playlist-new.c:

#0 playlist_delete_selected (playlist_num=8630720) at playlist-new.c:1425
#1 0x00007fffed242215 in playlist_keypress_cb (widget=<optimized out>,
event=<optimized out>, unused=<optimized out>) at ui_gtk.c:581

Reproducible on the older Fedora 16 (x86_64).

#4 Updated by John Lindgren over 8 years ago

  • Subject changed from gtkui playlist "Cut" action fails since 3.2-beta1 to Symbol collision: playlist_delete_selected
  • Status changed from New to Closed
  • Priority changed from Minor to Major
  • Target version set to 3.2.2
  • % Done changed from 0 to 100
  • Affects version 3.2.1 added
  • Affects version deleted ()

playlist_delete_selected(), in Audacious core, is not supposed to be visible to plugins. Fixed in master (and will be backported to 3.2.2):
https://github.com/audacious-media-player/audacious/commit/ba7c575a80d9782eacff6bf2f3ad246d3fd18a68

Also available in: Atom PDF