Project

General

Profile

Feature #874

openmpt:Reduce libopenmpt version requirement (patch included)

Added by Jim Turner 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Trivial
Assignee:
-
Category:
plugins/openmpt
Target version:
Start date:
February 23, 2019
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

It looks like only one function requires v0.3, whereas Debian Stretch has v0.2.7x, and that a small change would allow building for Stretch. The request is to enable building and using the new openmpt plugin on Stretch-ish (additional) platforms.

I have both a Stretch and a Buster box, and was building first on Stretch and was successful in both instances with this small change, however I have very limited of sound files to test it with, but it seems to work. In addition to the patch, configure.ac:line#266 will need changing to: "libopenmpt >= 0.2)". Please review.

Thanks,

Jim

mptwrap.cc.diff (805 Bytes) mptwrap.cc.diff Jim Turner, February 23, 2019 06:27

History

#2 Updated by John Lindgren 8 months ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed
  • Category set to plugins/openmpt

Also available in: Atom PDF