Project

General

Profile

Bug #880

Wrong active area in some skins.

Added by Carlo Bramini 7 months ago. Updated 6 months ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Target version:
-
Start date:
March 09, 2019
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

With some skins, some buttons can be activated when pressing on regions where those buttons do not exist.
For example, open the Refugee skin and press with the mouse as shown in the attached screenshot: the button "Rand." can be activated on and off by pressing in that point, but it should not.

Other skins:
- Classic
- Classic1.3
- Ivory
- Osmosis
- TinyPlayer
are affected on both random and repeat buttons.

Sincerely.

aud.png (71.8 KB) aud.png How to reproduce the issue Carlo Bramini, March 09, 2019 14:30

History

#1 Updated by John Lindgren 6 months ago

The active area is correct (matches Winamp 2.x). The skins you mention are visually misleading because part of the shuffle button doesn't look like a button. See https://github.com/audacious-media-player/audacious-plugins/blob/master/src/skins-data/Skins/Refugee/shufrep.png for example:

I already fixed the Default skin under #397. I'm not going to consider visual imperfections in the other skins as a "bug" nor spend my time going through and fixing all of them. If you would like to submit fixes, please feel free to do so, and open a pull request.

#2 Updated by John Lindgren 6 months ago

  • Status changed from New to Rejected

Also available in: Atom PDF