Project

General

Profile

Bug #904

MediaPlayer control keys don't work anymore with new KDE Plasma version

Added by Aurélien B. 27 days ago. Updated 26 days ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
plugins/mpris2
Target version:
-
Start date:
September 24, 2019
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Hi,

Thanks for this great software!

Since the last Plasma update, it seems that the MediaPlayer interface requirements are more strict. Someone said that Audacious doesn't implement the interface properly, and that's why MediaPlayer controls don't work anymore.

From the Reddit thread (https://www.reddit.com/r/kde/comments/czmyq8/last_plasma_update_broke_media_controller/):

===

Audacious doesn't implement MPRIS correctly. It lacks the SupportedUriSchemes and SupportedMimeTypes properties on the MediaPlayer interface which are mandatory.

This update made media controller more strict about following the spec to guard plasma against fishy DBus traffic. We've had plasmashell crash in the past by players sending incorrect replies (e.g. string-string dict instead of string-variant dict, triggering asserts in libdbus). Sorry about that.

===

What can we do to fix this, so that we can still use the great Audacious with KDE?

Should you need any help, feel free to ask.

History

#1 Updated by Thomas Lange 26 days ago

  • Priority changed from Major to Minor
  • Status changed from New to Closed

This has already been reported and implemented. Duplicate of #900 and #901.

Also available in: Atom PDF