Project

General

Profile

Feature #92

Allow hiding main window without also hiding playlist window

Added by Christian Iversen over 8 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Major
Assignee:
-
Category:
plugins/skins
Start date:
April 01, 2012
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

I've used audacious since the beginning, and I've always used it in WinAMP-skin mode, with the main player window hidden, effectively making the playlist window the "real" window. Then I've used KDEs global shortcuts to control next, previous, etc. This in essence turns Audacious into an excellent light-weight, shortcut-controlled player.

However, Audacious as shipped in Ubuntu was very buggy. It simply kept crashing with the Oxygen-GTK theme. I've reported this to the Ubuntu bugtracker, and I have backtraces if you are interested.

The upshot of this is that I found a PPA (Package Archive) with considerably newer Audacious builds. I'm currently 3.2.1, which does not seem to crash. However, it no longer works the same! If I click "hide player window" in the menu, the playlist window is gone as well! It seems that these 2 windows also use the same X11 title, making it impossible to use global shortcuts, since they target more than 1 window. This change in title might be related to the regression. It seems that the playlist used to have its own ID, but no longer has.

Audacious know has a Global Shortcuts plugin, I know, but I've used it since long before it got that. I've now disabled my shortcuts, and enabled the Global Shortcuts plugin, which is a workaround.

I really hope this can be fixed, it's quite a usage regression from the older Ubuntu version (except for the crashing). I'm currently on the GTK skin, but I'd like to go back to what I'm used to.

History

#1 Updated by John Lindgren over 8 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from Regression: In classic-skin mode, it is no longer possible to hide the player window without also hiding the playlist window! to Allow hiding main window without also hiding playlist window
  • Target version deleted (3.2.3)
  • Category changed from core to plugins/skins

Actually this is intended, that all three windows are hidden when the main window is hidden. Any issue with keyboard shortcuts is probably unrelated; you should open a separate report.

#2 Updated by Christian Iversen over 8 years ago

I must ask, why is this intended? It breaks a perfectly good use case, and what do you get in return? Nothing? Is there some not-so-obvious advantage to forcing all windows to hide with the main window?

#3 Updated by John Lindgren over 8 years ago

The advantage would be that you don't have to hide all three separately.

#4 Updated by Christian Iversen over 8 years ago

But there is already a Global Shortcut for "hide/show app", why make it impossible to show only the playlist? Can't I convince you to make it optional, at least? :)

You're ruining a perfectly good use case, that has worked since XMMS. Pretty please? :-)

#5 Updated by John Lindgren over 3 years ago

  • Status changed from New to Rejected

Closing some old requests that no one has had time to implement.

Also available in: Atom PDF