Project

General

Profile

Bug #926

Need to press twice for shortcut to work

Added by aur as 4 months ago. Updated 4 months ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Target version:
-
Start date:
December 08, 2019
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

It's so great to have global shortcuts available from Global Hotkeys Plugin. I like top use Super + F1 to Super + F5 as shortcuts like this:

  • Super + F1: Previous
  • Super + F2: Play
  • Super + F3: Pause/Resume
  • Super + F4: Stop
  • Super + F5: Next track

But I have to press Super + F5 twice to go to the next track. To reproduce:

  1. Go to Plugins > Global Hotkey > Settings
  2. Set Next track to Super + F5
  3. Press Super + F5 once and see that nothing happens
  4. Press Super + F5 quickly again, and the next track is played

If I set the shortcuts to something else like F1 for Previous track and Ctrl + F5 for Next track, it works fine. But those will conflict if I have a browser open, or another program, which is why I prefer Super + F1 to Super + F5, which haven't so far been used by another program.

Ubuntu 18.04
Audacious 3.10

History

#1 Updated by John Lindgren 4 months ago

  • Status changed from New to Rejected

Something else in your system is probably grabbing Super + F5. There is nothing special in our handling of that particular combination.

Not a bug.

#2 Updated by aur as 4 months ago

You're right, something was probably hogging the Super key ... I tried to understand why with xev, but just resorted to use Shift + Ctrl in stead, which works fine in Ubuntu 18.04:

  • Shift + Ctrl + F1: Previous
  • Shift + Ctrl + F2: Play
  • Shift + Ctrl + F3: Pause/Resume
  • Shift + Ctrl + F4: Stop
  • Shift + Ctrl + F5: Next track

Also available in: Atom PDF