Project

General

Profile

Feature #98

Add Sndio plugin

Added by Brad Smith over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
-
Target version:
Start date:
April 12, 2012
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

Add Sndio plugin. The following diff adds support for the Sndio API used on OpenBSD.

0001-Add-Sndio-plugin.patch (13.7 KB) 0001-Add-Sndio-plugin.patch Brad Smith, April 12, 2012 01:30
0001-Add-Sndio-plugin.patch (14.1 KB) 0001-Add-Sndio-plugin.patch Brad Smith, May 12, 2012 05:52

History

#1 Updated by Brad Smith over 7 years ago

Here is an updated diff which includes an updated Sndio plugin adding a bunch of bug fixes.

revision 1.5
date: 2012/05/10 22:42:24; author: ratchov; state: Exp; lines: +10 -1
use milliseconds for the buffer size, in the sndio backend

revision 1.4
date: 2012/05/09 20:53:35; author: ratchov; state: Exp; lines: +96 -83
Update the plug-in to the newer 3.x plug-in semantics. Fixes audacious
unpausing by itself as various other bugs caused by using the version
2.x plug-in.

#2 Updated by MichaƂ Lipski over 7 years ago

  • Target version deleted (3.2.3)

#3 Updated by John Lindgren over 7 years ago

  • Status changed from New to Closed
  • Target version set to 3.3
  • % Done changed from 0 to 100

I've added the plugin and removed the written_time() and set_written_time() functions, which are no longer required. I have not had time to get an OpenBSD system running to test on, so please let me know if there are any problems.

https://github.com/audacious-media-player/audacious-plugins/commit/02706adf601293f36fb0c8f2cd424620a3ea889c
https://github.com/audacious-media-player/audacious-plugins/commit/45ca2c7b1822290b8fa0999f04874f3da5dfd917

#4 Updated by Brad Smith over 7 years ago

John Lindgren wrote:

so please let me know if there are any problems.

Thank you. This in itself is a step forward. It'll be much easier
to submit patches against what has been commited even if anything
comes up with the code as is with the 3.3 release.

Also available in: Atom PDF