Project

General

Profile

Bug #986

Dragging from the Audacios window Moves rather than Copies now

Added by Dale Powell 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
plugins/qtui
Target version:
Start date:
May 12, 2020
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

I have used Audacious for many many years to sort out new music for mixing with, dragging to copy files I wish to add to my DJ list and external playlists by dragging from the Audacious window into the folder I wish to copy them to. This no longer Copies but rather Pastes the file, which is extremely disrupting! This is likely to leave me (and very likely already has as I only just noticed!!! :( ) with albums and folders missing files where I gone to copy them to the DJ folder and them moved the whole (except now not complete) album folder to my main music directory.

History

#1 Updated by John Lindgren 6 months ago

What file manager do you use? I tried it with Nemo and the file is copied, not moved.

#2 Updated by John Lindgren 6 months ago

Interestingly, Dolphin brings up a menu with "Move Here", "Copy Here", and "Link Here" options.

#3 Updated by John Lindgren 6 months ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed
  • Category set to plugins/qtui

#4 Updated by Dale Powell 6 months ago

Sorry for the delay but seems you managed to recreate it without my assistance. Thanks for the speedy work.

I experienced it with Thunar, so may have been an issue between Qt and GTK (although Google tells me Dolphin now uses Qt so maybe not.)

I've not built from specific commits from Git, only either Branches or PRs. Or should I just wait for it to make its way to Manjaro through Arch once the new versions are officially released? Is there anywhere that says which version this change will come into play?

#5 Updated by John Lindgren 6 months ago

It will be in 4.0.4. If you're comfortable with building packages from the AUR you can install audacious-git and audacious-plugins-git from there.

#6 Updated by Dale Powell 6 months ago

Just installed from AUR using yay and can confirm the issue is fixed for me :)

#7 Updated by John Lindgren 5 months ago

  • Target version set to 4.0.4

Also available in: Atom PDF