Bug #138

Song slider broken on GTK >= 3.5.0

Added by Jean-Louis Dupond over 4 years ago. Updated over 4 years ago.

Status:Closed Start date:June 28, 2012
Priority:Major Due date:
Assignee:- % Done:

100%

Category:plugins/gtkui
Target version:3.3
Affects version:

Description

Hi

In GTK 3.5.0 there was some fix to change the behavior of the GtkScale slider.
Therefor there is no more hack needed to make it working as we want, so the hack should be undone for GTK 3.5.0 and bigger.

Attached a patch that fixes this issue.

Thanks for review!

slider_fix.patch Magnifier (791 Bytes) Jean-Louis Dupond, June 28, 2012 00:27

GTK35.patch Magnifier (1.3 kB) Thomas Lange, June 28, 2012 17:35

Associated revisions

Revision 1957913f
Added by John Lindgren over 4 years ago

gtkui: Remove hack that made the left mouse button behave like the middle button as it breaks the intended behavior of GtkSlider in GTK+ 3.5.x. Closes: #138.

Revision ad5a7786
Added by John Lindgren over 4 years ago

gtkui: Remove hack that made the left mouse button behave like the middle button as it breaks the intended behavior of GtkSlider in GTK+ 3.5.x. Closes: #138.

History

#1 Updated by John Lindgren over 4 years ago

It has already been mentioned that the workaround is no longer necessary for GTK+ 3.5, and perhaps we will take it out once GTK+ 3.5 is released, but how is it "broken"?

(Edit: That is, when 3.5 becomes 3.6.)

#2 Updated by Jean-Louis Dupond over 4 years ago

Well i'm on Ubuntu Quantal which already has GTK+ 3.5.

Clicking on the slider doesn't do anything anymore.
You can only change position when dragging the slider.

I think the attached patch is the way to go.
Don't think its good to lose compatibility with GTK+ < 3.5

#3 Updated by Thomas Lange over 4 years ago

The two functions with the hack are no more needed at all.

In my opinion Audacious should really have these version checks too.
Now, not when 3.6.0 is released.
Generally I agree with your opinion, John. But not in this case.

By the way, rhythmbox got a commit today which fixes the same bug:
http://git.gnome.org/browse/rhythmbox/commit/?id=a16a8bb41090233a28778e45f277e94de091f773

#4 Updated by John Lindgren over 4 years ago

Jean-Louis Dupond wrote:

Clicking on the slider doesn't do anything anymore.
You can only change position when dragging the slider.

Hi, thanks for FINALLY STATING WHAT THE PROBLEM IS. Useless discussions (and disagreements) can go on a long time if you leave out the critical piece of information. (Mr. Lange, I'm talking to you also.)

#5 Updated by John Lindgren over 4 years ago

  • Status changed from New to Closed
  • Target version set to 3.3
  • % Done changed from 0 to 100

#6 Updated by Thomas Lange over 4 years ago

Do you really want to remove compatibility with GTK <= 3.4 with Audacious 3.3?
What happens if "someone" files bug report #139 titled "Song slider broken on GTK <= 3.4.3"?

Will you reject it? Gosh...

#7 Updated by John Lindgren over 4 years ago

We haven't "removed compatibility" with GTK+ 3.4. We only reverted to the behavior GtkSlider has in other applications: you use middle-click to set the position directly (just like on a scrollbar). And yes, if "someone" has the gall to file that bug report, I will reject it.

Also available in: Atom PDF