Bug #398

skins: Double-click on bitrate textbox leads to strange dock behavior

Added by Thomas Lange almost 4 years ago. Updated almost 4 years ago.

Status:Closed Start date:February 01, 2014
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:plugins/skins
Target version:3.5
Affects version:3.4.3

Description

If the textbox which contains the bitrate and quality is double-clicked,
the main window shades.

Then this window cannot be closed anymore
because the equalizer or playlist window follows the mouse cursor.

This is caused by a wrong Y value in "skins/ui_main.c/mainwin_mouse_button_press()".
What is going wrong here? The coordinates around the textbox are all correct.

Associated revisions

Revision fa4e6321
Added by John Lindgren almost 4 years ago

skins: GdkEventButton x,y values are relative to the GdkWindow clicked on. Closes: #398.

History

#1 Updated by John Lindgren almost 4 years ago

  • % Done changed from 0 to 100
  • Target version set to 3.5
  • Status changed from New to Closed
  • Affects version 3.4.3 added

The problem is that the x and y values in the GdkEventButton structure are relative to the GdkWindow clicked on (in this case, the textbox rather than the main window). I have fixed this by ignoring events that do not come from the GdkWindow of the main window. Possibly better would be to adjust the x and y values by the relative offset of the two GdkWindows, but I don't think that's necessary here.

https://github.com/audacious-media-player/audacious-plugins/commit/fa4e6321cd0a4ef1944e97975d578820b6b6d527

Also available in: Atom PDF