Project

General

Profile

CD playback, playlist not updating new media

Added by Todd Dreadmeat almost 8 years ago

hi, i'm using Audacious 3.2.1, Debian Wheezy [testing] and XFCE
the issue i have is the playlist isn't updating to show the new CD in the drive, Audacious 2.4.4 does the same thing, i just upgraded today to 3.2.1
it'll just load the previous info, even though it'll play the new cd, i have to close the player and reopen it for the playlist to update.
even if i shift+d [delete playlist] it still won't update and show the correct artist/track info etc
is it keeping the data in a cache or something?
how can i force it to load the new CD's info? shouldn't it just read the cd-text and display that?
any hints or suggestions?

thanks
and g'day from Auckland, New Zealand too 8)


Replies (11)

RE: CD playback, playlist not updating new media - Added by John Lindgren almost 8 years ago

Please give steps to reproduce.

RE: CD playback, playlist not updating new media - Added by Todd Dreadmeat almost 8 years ago

open player, put cd in tray and close it, load the cd to the playlist.
the tracks appear in the playlist according to cddb [annoying, another story] play music.
eject cd, playlist clears itself, load new cd, the previous album is loaded, no new info loads.
even playing the new cd the track lengths will only allow the new song to play the previous albums length, eg if track 5 is 2:03 long then the newly loaded cd's track 5 will only play to 2:03 then just stop.
even if i manually clear the playlist this happens, the only thing that seems to work is closing the player then reopening it.
refreshing the playlist doesn't work, deleting it doesn't work, creating a new playlist doesn't work
i've tried dozens of cds, same every time.

i have subscribed to alerts on this thread now, oops.

RE: CD playback, playlist not updating new media - Added by Todd Dreadmeat almost 8 years ago

i just reproduced it identically on another computer [a dell laptop] with the latest version of audacious 3.2.1
can anyone else reproduce this?

RE: CD playback, playlist not updating new media - Added by John Lindgren over 7 years ago

This seems to be a libcdio problem; I am looking into a workaround.

RE: CD playback, playlist not updating new media - Added by Todd Dreadmeat over 7 years ago

ok cool, what am i meant to do with that info though?
edit a config file?

RE: CD playback, playlist not updating new media - Added by John Lindgren over 7 years ago

No, patch the source and rebuild or just wait for 3.2.2.

RE: CD playback, playlist not updating new media - Added by Todd Dreadmeat over 7 years ago

ok cool, thanks for that, i suppose i'll have to wait for 3.2.2 unless you can point me in the right direction for patching it?
i installed 3.2.1 from the repos but i've installed stuff from source in the past [i'm not a linux ninja though]
i'm not getting email updates for any of your responses for some reason.

RE: CD playback, playlist not updating new media - Added by Todd Dreadmeat over 7 years ago

3.2.2 updated today, this problems still persists.
could i assume the plugins will be updated soon? only the player updated today that i saw.

thanks.

RE: CD playback, playlist not updating new media - Added by Thomas Lange over 7 years ago

According to http://packages.debian.org/wheezy/audacious-plugins there should be an update for you.
And your problem is only related to audacious-plugins so don't wonder why it's still not fixed with 3.2.1.

RE: CD playback, playlist not updating new media - Added by Todd Dreadmeat over 7 years ago

g'day, the plugins updated too and now the problem is fixed! yay! 8)

    (1-11/11)