Project

General

Profile

Feature request: .rsn support

Added by Super Nintendo over 7 years ago

Howdy, any chance you guys could add .rsn support in the next update of Audacious?:)

http://kittylambda.com/rsn_plugin_for_audacious
http://thatcadguy.blogspot.se/2010/03/rsnc-rsn-plugin-for-audacious-media.html


Replies (4)

RE: Feature request: .rsn support - Added by Super Nintendo over 7 years ago

I'm having issues compiling the .rsn patch from kittylambda with audacious. How do I solve this?

Entering directory src.
Entering directory tonegen.
Leaving directory tonegen.
Entering directory metronom.
Leaving directory metronom.
Entering directory vtx.
ay8912.c: In function ‘check_magic’:
ay8912.c:79:3: warning: implicit declaration of function ‘fprintf’ [-Wimplicit-function-declaration]
ay8912.c:79:3: warning: incompatible implicit declaration of built-in function ‘fprintf’ [enabled by default]
ay8912.c:79:11: error: ‘stderr’ undeclared (first use in this function)
ay8912.c:79:11: note: each undeclared identifier is reported only once for each function it appears in
ay8912.c: In function ‘ayemu_set_regs’:
ay8912.c:320:3: warning: incompatible implicit declaration of built-in function ‘fprintf’ [enabled by default]
ay8912.c:320:3: error: ‘stderr’ undeclared (first use in this function)
Failed to compile ay8912.c (plugin)!
make5: * [ay8912.plugin.o] Error 1
make4:
[all] Error 2
make3:
[subdirs] Error 1
make2:
[all] Error 2
make1:
[subdirs] Error 1
make: *
[all] Error 2

RE: Feature request: .rsn support - Added by John Lindgren over 7 years ago

You need to include the stdio.h header before you can use fprintf() or stderr.

EDIT: Why are you recompiling audacious-plugins? You can compile and install a third-party plugin without recompiling all the others.

RE: Feature request: .rsn support - Added by Super Nintendo over 7 years ago

I'm just a normal ubuntu user so i have no idea about this sort of stuff, i'm just following what it says on http://thatcadguy.blogspot.se/2010/03/rsnc-rsn-plugin-for-audacious-media.html

Still getting errors with stdio.h added, so what's the easier way to get .rsn compiled?:)

RE: Feature request: .rsn support - Added by Michael Schwendt over 7 years ago

Typically, you would just install the Ubuntu packages for Audacious and its plugins plus the -dev package, which is needed for building software using the Audacious API. The rsn plugin source code ought to build happily, finding and using the installed files from the Ubuntu packages.

However, the top link at the page you refer to redirects at http://kittylambda.com/rsn_plugin_for_audacious which is about Audacious 2.4.3. There have been major changes since then, so it could be that this particular plugin won't compile without being updated beforehand.

    (1-4/4)