Project

General

Profile

Bug #103

New GtkToolbar: cursor focus bug

Added by Thomas Lange about 8 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
Major
Assignee:
-
Category:
plugins/gtkui
Start date:
April 25, 2012
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

The new GtkToolbar brought a really annoying bug:

If you make a mouse click under/above the time slider, the cursor becomes a "fist" (hard to explain)
and you can't do anything except moving the cursor.

GTK+ 3.4.1
audacious-git (25th April)
Theme: Orion and Greybird tested

For a better explanation, a short video is attached.

Example.ogv (161 KB) Example.ogv Thomas Lange, April 25, 2012 01:06

History

#1 Updated by Thomas Lange about 8 years ago

Forgot to complete the title but can't edit it anymore.
Sorry, please change it to "New GtkToolbar: cursor focus bug"

#2 Updated by Michał Lipski about 8 years ago

  • Subject changed from New GtkToolbar: to New GtkToolbar: cursor focus bug

#3 Updated by Michał Lipski about 8 years ago

I can't reproduce it. GTK+ 3.4.1, tested with Orion and Adwaita themes.

#4 Updated by Thomas Lange about 8 years ago

Could it be related to XFCE? I just tried reproducing with Gnome 3 and was unable to do it.
But there's still a problem: the time slider and the time label get paused (as shown in the video).
Are you able to reproduce this?

#5 Updated by Michał Lipski about 8 years ago

Hmm, actually yeah. When I click on the toolbar, the time slider and the time label get paused.

It seems that "button-press-event" signal gets emitted for the slider... but there's no "button-release-event" afterwards.

#6 Updated by John Lindgren about 8 years ago

  • Status changed from New to Rejected

We don't do anything special with cursors, or even look at any mouse events on the toolbar, so this is definitely a GTK+ bug. Closing.

#7 Updated by Thomas Lange about 8 years ago

Downgrading GTK+ to 3.2 fixed the cursor problem, so it is actually a regression in GTK+.
The slider/label pausing remains the same.

Do you think the cursor related issue needs to be reported to XFCE or GTK+?

#8 Updated by Thomas Lange about 8 years ago

The problem is "GTK_STYLE_CLASS_PRIMARY_TOOLBAR" in ui_gtk.c.
Replacing it with "GTK_STYLE_CLASS_TOOLBAR" or commenting the two context lines fixes this bug.
But the toolbar loses its different appearance.

Also available in: Atom PDF