Project

General

Profile

Bug #1041

Crash when switching from default Qt interface to Skins (latest git)

Added by Jim Turner 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
plugins/qtui
Target version:
Start date:
December 17, 2020
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

Just what title says. Pbm is only in latest GIT (2 different versions of Qt5 tested). Pbm was not present in last GIT build on 12/2. Problem does not occur in GTK interface.

Seems to be the assert() in dock.cc:register_dock_host() due to possibly failure to call unregister_dock_host() on leaving Qt interface before skins-qt starts up and calls register_dock_host(), due to changes in how the main window is now being shut down?

Output:

$>audacious
audacious: dock.cc:169: void audqt::register_dock_host(audqt::DockHost*): Assertion `!s_host' failed.
Aborted

Steps to reproduce:

Start Audacious (starts in default Qt interface), then switch to skins-qt interface, immediate crash.

History

#1 Updated by John Lindgren 10 months ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

Fixed, thanks for catching that!

#2 Updated by Thomas Lange 10 months ago

  • Target version set to 4.1

Also available in: Atom PDF