Project

General

Profile

Feature #11

[gtkui] Queue position and entry number columns are unnecessarily wide

Added by Artem S. Tashkinov almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
plugins/gtkui
Target version:
Start date:
December 20, 2011
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

Please, see the attached screenshot.

125 px combined, which is wrong I suppose.

Gtk 2.22 here.

columns.png (7.09 KB) columns.png Artem S. Tashkinov, December 20, 2011 19:12

History

#1 Updated by John Lindgren almost 8 years ago

It's because GTK's method of calculating the best-fit column width is too slow for large playlists. Hence we have to use a fixed width.

#2 Updated by John Lindgren almost 8 years ago

  • Subject changed from [regression] Queue position and entry number columns are unnecessarily wide in Audacious 3.2-alpha1 to [gtkui] Queue position and entry number columns are unnecessarily wide

#3 Updated by Thomas Lange almost 8 years ago

I've found this example which could help:
http://www.gtkforums.com/viewtopic.php?p=10694&sid=5dbb54b0beeaccd1866c666af2979b13#p10694

A button like in this example with an appearing border if the cursor is above it would be also nice.

#4 Updated by John Lindgren almost 8 years ago

Thomas, you seem to be cross-posting about bug #6, which has been fixed already.

#5 Updated by John Lindgren almost 8 years ago

  • Category set to plugins/gtkui

#6 Updated by John Lindgren over 7 years ago

  • Status changed from New to Closed
  • Target version set to 3.2.3
  • % Done changed from 0 to 100
  • Affects version 3.2.2 added
  • Affects version deleted ()

Also available in: Atom PDF