Project

General

Profile

Bug #267

skins: Different appearance of menus

Added by Thomas Lange over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
plugins/skins
Start date:
March 08, 2013
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

The appearance of menus looks different with the Winamp interface.
Especially the background colour of the selection is not the same.
With some themes the text can be even unreadable (-> screenshots with Ubuntu).

gtk_interface.png (113 KB) gtk_interface.png orange background colour Thomas Lange, March 08, 2013 23:19
winamp_interface.png (177 KB) winamp_interface.png white background colour, orange square Thomas Lange, March 08, 2013 23:19

History

#1 Updated by John Lindgren over 7 years ago

Any idea why this happens? Those colors are all set by GTK+; we don't change them.

#2 Updated by Michael Schwendt over 7 years ago

This is interesting. It's reproducible with gtk3-3.7.12 and Fedora 19 development. And worse, because the default GNOME 3 colouring results in grey menus and grey highlighting, so the current selection cannot be seen well (except for the slightly changing shades of grey for keyboard shortcut text or submenu arrows).

Sometimes when opening a dialog in the Winamp interface, the top entry is blue (as it should be), but doesn't react to mouse pointer movement. Highlighting of the entries below it is grey on grey.

#3 Updated by Thomas Lange over 7 years ago

John Lindgren wrote:

Any idea why this happens? Those colors are all set by GTK+; we don't change them.

No, I have no clue what's wrong here.

#4 Updated by Michael Schwendt over 7 years ago

Went back to older dist releases to see when this has started:

not reproducible: Fedora 17 with gtk3-3.4.4-1.fc17.x86_64 and a test-build of Audacious 3.4.4
reproducible: Fedora 18 with gtk3-3.6.4-1.fc18.x86_64 and Audacious 3.4.4

Also available in: Atom PDF