Project

General

Profile

Bug #468

[Patch] Qt: Support left mouse button in time slider

Added by Thomas Lange almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
plugins/qtui
Target version:
Start date:
October 14, 2014
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

The attached patch adds the support for using
the left mouse button in the time slider.

Please review.

qt_time_slider.patch (1.07 KB) qt_time_slider.patch Thomas Lange, October 14, 2014 16:15

History

#1 Updated by John Lindgren almost 5 years ago

Looks good.

#2 Updated by Thomas Lange almost 5 years ago

Thanks, I will commit it if William confirms that it works on Mac OS.

#3 Updated by William Pitcock almost 5 years ago

Can you explain the problem here? Doesn't the time slider already work with left mouse button?

#4 Updated by William Pitcock almost 5 years ago

I tested the patch on Mac and it causes no regressions there, but I don't understand what the goal of the patch is, it seems to be the same behaviour as it was before on Mac, so I am not sure what you are trying to accomplish.

Please clarify the need for the patch prior to committing it, as I don't understand why we need it.

#5 Updated by Thomas Lange almost 5 years ago

On Linux the left mouse button has no effect on the slider.
If you want to change its position you have to use the scroll wheel.

Also available in: Atom PDF