Project

General

Profile

Bug #523

FLAC plugin broken on Windows 8.1, FFMPEG plugin works

Added by Jonathan Lane over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
plugins/flac
Target version:
Start date:
March 20, 2015
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

Playing back certain FLAC files on Windows 8.1 in Audacious 3.6 will immediately cause Audacious to crash and the application to close. Disabling the FLAC plugin and relying on the FFMPEG plugin to handle FLAC playback works. I suspect this is a bug in the upstream FLAC library, since Clementine 1.2.3 exhibits very similar behavior on Windows 8.1, and they determined it was a bug in dependency code.

flac.jpg (295 KB) flac.jpg JM Phone Home, May 13, 2015 03:47

History

#1 Updated by John Lindgren over 5 years ago

Please attach an example file.

#2 Updated by Jonathan Lane over 5 years ago

Each of the files I've experienced this problem with exceeds 5MB in size, so I can't attach them. Here is a link to one of the files:

http://a.pomf.se/aikkfo.flac

#3 Updated by John Lindgren over 5 years ago

I can't reproduce the crash on Windows 7.

#4 Updated by John Lindgren over 5 years ago

Can anyone else reproduce this? Preferably on a Windows 7 machine?

#5 Updated by Artem S. Tashkinov over 5 years ago

John Lindgren wrote:

Can anyone else reproduce this? Preferably on a Windows 7 machine?

I can confirm that Audacious 3.6.1 is crashing on Windows 8.1 64 with the provided FLAC file but since the reporter says it's a problem with the upstream library this bug report is actually invalid.

In Windows 7 64 Audacious doesn't crash.

#6 Updated by John Lindgren over 5 years ago

Is there an upstream fix yet? It would be nice to include a patch in the next Windows build if one is available.

#8 Updated by John Lindgren over 5 years ago

I'm skeptical. Has anyone confirmed (i.e. recompiled libflac and tested) that this really fixes the crash?

#9 Updated by Artem S. Tashkinov over 5 years ago

John Lindgren wrote:

I'm skeptical. Has anyone confirmed (i.e. recompiled libflac and tested) that this really fixes the crash?

I surely won't test it, 'cause I have exactly zero desire to install Windows 8.1 again, besides mingw which takes a lot of time to properly set up ;-)

The OP ought to test it, but so far it seems like he's lost interest to this bug report.

#10 Updated by John Lindgren over 5 years ago

Artem S. Tashkinov wrote:

I surely won't test it, 'cause I have exactly zero desire to install Windows 8.1 again

Yeah, me too.

#11 Updated by Jonathan Lane over 5 years ago

Unfortunately I can't test this either, since my Windows 8.1 machine is a company laptop and I can't install a full MinGW toolchain to rebuild libflac.

#12 Updated by JM Phone Home over 5 years ago

!!
Audacious 3.6.1 crashes on windows 8.1 with flac files, any hint?

#13 Updated by Artem S. Tashkinov over 5 years ago

JM Phone Home wrote:

!!
Audacious 3.6.1 crashes on windows 8.1 with flac files, any hint?

You may help by compiling libflac with the proposed patch. There's no need to post screenshots or any debugging information - the crash has been successfully reproduced.

#14 Updated by JM Phone Home over 5 years ago

I apologize for posting the screenshot, I followed the link upper on this section, https://git.xiph.org/?p=flac.git;a=commitdiff;h=a84587061cab4d55fa2668ea431d3b61e711c8a3 but I don't know how to compile on Windows, Would yo be so kind to redirect me to any link related where I can learn how to do it? Also installing 3.6.1 version under Ubuntu 15.04 with the last kernel I have problems like this:

ERROR plugin-init.cc:132 [start_single]: No output plugin found.
(Did you forget to install audacious-plugins?)

But the plug in is already installed from the same repository, Do I must report this on a different tag?

I will appreciate any help, thank you!

#15 Updated by John Lindgren over 5 years ago

  • Status changed from New to Closed
  • Target version set to 3.6.2
  • % Done changed from 0 to 100

The 3.6.2a build has libflac configured with --disable-sse. This fixes the crash for me on a Windows 10 preview build.

#16 Updated by Sergey Bromirskiy about 5 years ago

I've tested 3.6.2a and 3.7beta1 versions on windows 8 and 8.1 and found similar problem with flac plugin. Adding flac files to play list very frequently causes Audacious crash. Disabling flac plugin lets add and playback flac files.

Also available in: Atom PDF